Jump to content
osx86.org

Broadcom NetLink Gigabit Ethernet BCM57785 1.0


About This File

Solution for those who updated to Mac OS X 10.7.4 and their Ethernet Adaptor Stopped Working

Patched for Broadcom NetLink Gigabit Ethernet BCM57785 PCI ID 14e4,16b5.

Please use stock IONetworkingFamily.kext and Install Kext in /S/L/E then Repair Permissions

Works for Packard Bell EasyNote TS-11HR, and Acer and Similar HackBooks

Also Works tested for 10.6.x, 10.7.x, and 10.8 DP3

Kind Regards,

Ash

Credits Adlan: - http://www.insanelymac.com/forum/index.php?showtopic=247470




User Feedback

Recommended Comments

Looking at Info.plist I didn't see a PCI ID match for BCM57781. Can you add that? PCI ID 14e4,16b1. Thanks!

Share this comment


Link to comment
Share on other sites

i have a problem with BCM57781, its detected as well, but wont get DHCP ip

Share this comment


Link to comment
Share on other sites

Thanks for your work but i try on Packard Bell EasyNote TS-11HR with 10.7.4 and the network not work. in prefs panel is all ok, but when i connect on internet or on local network don't work.

I try to use static ip with the same results. Can you help us?

p.s. stock IONETWORKINGFAMILY.KEXT is the original kext in comboupd.

Share this comment


Link to comment
Share on other sites

I only made this fix so OS X can see my built-in ethernet and mac address. I use wireless and I can confirm this driver is no good because even when no ethernet cable is plugged in I get private IP address. best thing to do is to rewrite the driver so it supports more broadcom chipsets including this one. All this fix will do is help you get into mac app store and do other things that rely on the ethernet MAC address.credits still go to adlan why don't you try and contact him, find him on github

Share this comment


Link to comment
Share on other sites

Where do i get that file?

"stock IONETWORKINGFAMILY.KEXT is the original kext in comboupd"

I've only the original LionInstallerApp 10.7.4.

Is it possible to get this file on its own?

Best regards

Share this comment


Link to comment
Share on other sites

does it work for PCI ID 14E4-16B1?

I see you have mentioned 14E4-16B5, I did try it, but i am getting errors in verbose and cannot detect the device once the lion boots up.

I might have entered the PCI ID at wrong line.

I will keep trying, meanwhile, any help is appreciated :)

Cheers..

Lenovo Y570

intel i5 2410m with intel HD 3000

HM65 Chipset

nVidia GT 555m (havent found right kext for this, still trying different thing, getting infamous nVidia unknown 0mb error if GraphicsEnabler=Yes)

audio is still not working, but 2 be very frank i am not bothred about it.

:listening_headphone

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.